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under the root (or /docs) directory in your repository.

If you want to use another markup, choose a different builder in your settings.
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familiar with Read the Docs.
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ethernet-fmc-zynq-gem

Example design for using the [Quad Gigabit Ethernet FMC](http://ethernetfmc.com “Ethernet FMC”) with the Zynq/ZynqUS+ PS hard
Gigabit Ethernet MACs (GEM) and the GMII-to-RGMII IP.

![Ethernet FMC](http://ethernetfmc.com/wp-content/uploads/2015/07/zedboard_eth_fmc_3.jpg “Ethernet FMC”)

## Requirements

This project is designed for version 2019.2 of the Xilinx tools (Vivado/Vitis/PetaLinux).
If you are using an older version of the Xilinx tools, then refer to the
[release tags](https://github.com/fpgadeveloper/ethernet-fmc-zynq-gem/releases “releases”)
to find the version of this repository that matches your version of the tools.

In order to test this design on hardware, you will need the following:


	Vivado 2019.2


	Vitis 2019.2


	PetaLinux SDK 2019.2


	[Ethernet FMC](http://ethernetfmc.com “Ethernet FMC”)


	One of the below listed Zynq or Zynq Ultrascale+ boards


	For designs containing AXI Ethernet Subsystem IP: [Xilinx Soft TEMAC license](http://ethernetfmc.com/getting-a-license-for-the-xilinx-tri-mode-ethernet-mac/ “Xilinx Soft TEMAC license”)




## Supported carrier boards


	Zynq-7000 [ZedBoard](http://zedboard.org “ZedBoard”)
* LPC connector


	[MicroZed FMC Carrier](http://zedboard.org/product/microzed-fmc-carrier “MicroZed FMC Carrier”) with [MicroZed 7020](http://microzed.org “MicroZed”)
* LPC connector


	Zynq-7000 [PicoZed FMC Carrier Card V2](http://zedboard.org/product/picozed-fmc-carrier-card-v2 “PicoZed FMC Carrier Card V2”) with [PicoZed 7030](http://picozed.org “PicoZed”)
* LPC connector


	Zynq-7000 [ZC706 Evaluation board](http://www.xilinx.com/products/boards-and-kits/ek-z7-zc706-g.html “ZC706 Evaluation board”) (LPC only)
* LPC connector


	Zynq UltraScale+ [ZCU102 Evaluation board Rev 1.0](http://www.xilinx.com/products/silicon-devices/soc/zynq-ultrascale-mpsoc.html “ZCU102 Evaluation board Rev 1.0”)
* HPC0 connector
* HPC1 connector (3 ports only)


	Zynq UltraScale+ [ZCU104 Evaluation board](https://www.xilinx.com/products/boards-and-kits/zcu104.html “ZCU104 Evaluation board”)
* LPC connector


	Zynq UltraScale+ [ZCU106 Evaluation board](https://www.xilinx.com/products/boards-and-kits/zcu106.html “ZCU106 Evaluation board”)
* HPC0 connector
* HPC1 connector (2 ports only)


	Zynq UltraScale+ [UltraZed PCIe Carrier Card](http://zedboard.org/product/ultrazed-pcie-carrier-card “UltraZed PCIe Carrier Card”) with [UltraZed-EG](http://zedboard.org/product/ultrazed-EG “UltraZed”)
* LPC connector


	Zynq UltraScale+ [UltraZed EV Carrier Card] (http://zedboard.org/product/ultrazed-ev-carrier-card “UltraZed EV Carrier Card”)
* HPC connector


	Zynq UltraScale+ [TE0808-04-09-1EE-S Starter Kit](https://shop.trenz-electronic.de/en/TE0808-04-09-1EE-S-TE0808-04-09-1EE-S-Starter-Kit “TE0808-04-09-1EE-S Starter Kit”) with [TE0808 UltraSOM+ MPSoC Module](https://shop.trenz-electronic.de/en/TE0808-04-09EG-1EE-UltraSOM-MPSoC-Module-with-Zynq-UltraScale-XCZU9EG-1FFVC900E-4-GB-DDR4 “TE0808 SoM”)
* HPC connector




## Description

This project demonstrates the use of the Opsero [Quad Gigabit Ethernet FMC](http://ethernetfmc.com “Ethernet FMC”).
The design demonstrates use of the GMII-to-RGMII IP core to connect the hard GEMs of the Zynq PS to the Ethernet FMC
PHYs. All designs use the hard GEMs but some also use AXI Ethernet Subsystem IP.

![Ethernet FMC Quad Gig AXI Ethernet](http://ethernetfmc.com/wp-content/uploads/2014/10/qgige_gmii_to_rgmii.png “Zynq Quad Gig Ethernet All AXI Ethernet”)

## Build instructions

To use the sources in this repository, please follow these steps:

### Windows users


	Download the repo as a zip file and extract the files to a directory
on your hard drive –OR– Git users: clone the repo to your hard drive


	Open Windows Explorer, browse to the repo files on your hard drive.


	In the Vivado directory, you will find multiple batch files (*.bat).
Double click on the batch file that is appropriate to your hardware,
for example, double-click build-zedboard.bat if you are using the ZedBoard.
This will generate a Vivado project for your hardware platform.


	Run Vivado and open the project that was just created.


	Click Generate bitstream.


	When the bitstream is successfully generated, select File->Export->Export Hardware.
In the window that opens, tick “Include bitstream” and “Local to project”.


	Return to Windows Explorer and browse to the Vitis directory in the repo.


	Double click the build-vitis.bat batch file. The batch file will run the
build-vitis.tcl script and build the Vitis workspace containing the hardware
design and the software application.


	Run Xilinx Vitis and select the workspace to be the Vitis directory of the repo.


	Connect and power up the hardware.


	Open a Putty terminal to view the UART output.


	In Vitis, select Xilinx Tools->Program FPGA.


	Right-click on the application and select Run As->Launch on Hardware (Single Application Debug)




### Linux users


	Download the repo as a zip file and extract the files to a directory
on your hard drive –OR– Git users: clone the repo to your hard drive


	Launch the Vivado GUI.


	Open the Tcl console from the Vivado welcome page. In the console, cd to the repo files
on your hard drive and into the Vivado subdirectory. For example: cd /media/projects/ethernet-fmc-zynq-gem/Vivado.





	In the Vivado subdirectory, you will find multiple Tcl files. To list them, type exec ls {*}[glob *.tcl].
Determine the Tcl script for the example project that you would like to generate (for example: build-zcu104.tcl),
then source the script in the Tcl console: For example: source build-zcu104.tcl


	Vivado will run the script and generate the project. When it’s finished, click Generate bitstream.


	When the bitstream is successfully generated, select File->Export->Export Hardware.
In the window that opens, tick “Include bitstream” and “Local to project”.


	To build the Vitis workspace, open a Linux command terminal and cd to the Vitis directory in the repo.


	The Vitis directory contains the build-vitis.tcl script that will build the Vitis workspace containing the hardware design and
the software application. Run the build script by typing the following command:
<path-of-xilinx-vitis>/bin/xsct build-vitis.tcl. Note that you must replace <path-of-xilinx-vitis> with the
actual path to your Xilinx Vitis installation.


	Run Xilinx Vitis and select the workspace to be the Vitis subdirectory of the
repo.


	Connect and power up the hardware.


	Open a Putty terminal to view the UART output.


	In Vitis, select Xilinx Tools->Program FPGA.


	Right-click on the application and select Run As->Launch on Hardware (Single Application Debug)




## Stand-alone software application

The software application used to test these projects is the lwIP Echo Server example that is built into
Xilinx Vitis. The application relies on the lwIP library (also built into Xilinx Vitis) but with a few modifications.
The modified version of the lwIP library is contained in the EmbeddedSw directory, which is added as a
local software repository to the Vitis workspace. See the “README.md” file in the Vitis directory for more information.

## PetaLinux

This repo contains a script and configuration files for a PetaLinux project for each one of the hardware platforms. To build
the PetaLinux project, please refer to the “README.md” file in the PetaLinux subdirectory of this repo.

## Board specific notes

### ZCU106


	The HPC0 connector on this board supports all 4 ports of the Ethernet FMC. This design uses up all 4 GEMs,




leaving the ZCU106’s on-board Ethernet port unusable.
* The HPC1 connector only has LA00-LA16 pins connected to the FPGA, therefore our example can only
support 2 ports of the Ethernet FMC. The ZCU106’s on-board Ethernet port connects to GEM3 and is usable in this design.

### ZCU102


	This design supports the ZCU102 Rev 1.0 board. Use a commit before 2017/02/13 for the older Rev-D board design.




Note that the FMC pinouts differ between Rev 1.0 and Rev D: https://www.xilinx.com/support/answers/68050.html
* The HPC0 design uses 4x GEMs to connect to ports 0-3 of the Ethernet FMC. This design uses up all 4 GEMs,
leaving the ZCU102’s on-board Ethernet port unusable.
* The HPC1 design uses 3x GEMs to connect to ports 0-2 of the Ethernet FMC. The 4th port is left unconnected
because certain pins required by the Ethernet FMC (namely LA30, LA31 and LA32) are left unconnected
on the HPC1 connector of the ZCU102 board. The ZCU102’s on-board Ethernet port connects to GEM3 and is usable
in this design.

### UltraZed


	The UltraZed design uses 4x GEMs to connect to ports 0-3 of the Ethernet FMC. This design uses up all 4 GEMs,




leaving the UltraZed PCIe Card’s on-board Ethernet port unusable.

### Trenz TE0808 Starter Kit

The base board TEBF0808 has a DIP switch that must be set correctly to enable VADJ of 1.8V. Set S5-4 to ON in order
to set VADJ to 1.8V.

This design uses up all 4 GEMs, leaving the TEBF0808’s on-board Ethernet port unusable.

### ZedBoard, MicroZed and PicoZed

When changing ETH_FMC_PORT from 0-2 to 3 (ie. when switching to GEM1), it has been noticed that
you have to power cycle the board. When the SDK project is configured for AXI Ethernet, it must make some
Zynq configurations that are not compatible with the GEM1 configuration.

The on-board Ethernet port on all of these designs is connected to GEM0 and is usable.

### Installation of MicroZed, PicoZed, UltraZed, TE0808 board definition files

To use the projects for the MicroZed, PicoZed and UltraZed, you must first install the board definition files
for those boards into your Vivado and Xilinx SDK installation.

The following folders contain the board definition files and can be found in this project repository at this location:

https://github.com/fpgadeveloper/ethernet-fmc-zynq-gem/tree/master/Vivado/boards/board_files


	microzed_7020


	picozed_7030_fmc2


	ultrazed_3eg_pciecc


	TE0808_9EG_1E




Copy those folders and their contents into the C:XilinxVivado2019.2databoardsboard_files folder (this may
be different on your machine, depending on your Vivado installation directory). You also need to make a copy into the
Xilinx SDK installation at this location: C:XilinxSDK2019.2databoardsboard_files.

### Single port limit

The echo server example design currently can only target one Ethernet port at a time.
Selection of the Ethernet port can be changed by modifying the defines contained in the
platform_config.h file in the application sources. Set PLATFORM_EMAC_BASEADDR
to one of the following values depending on the port you want to target, and the hardware platform:

#### ZedBoard, MicroZed and PicoZed designs


	Ethernet FMC Port 0: XPAR_AXIETHERNET_0_BASEADDR


	Ethernet FMC Port 1: XPAR_AXIETHERNET_1_BASEADDR


	Ethernet FMC Port 2: XPAR_AXIETHERNET_2_BASEADDR


	Ethernet FMC Port 3: XPAR_XEMACPS_1_BASEADDR


	On-board Ethernet port: XPAR_XEMACPS_0_BASEADDR




#### ZCU102 design (HPC0)


	Ethernet FMC Port 0: XPAR_XEMACPS_0_BASEADDR


	Ethernet FMC Port 1: XPAR_XEMACPS_1_BASEADDR


	Ethernet FMC Port 2: XPAR_XEMACPS_2_BASEADDR


	Ethernet FMC Port 3: XPAR_XEMACPS_3_BASEADDR


	ZCU102’s on-board Ethernet port: Not usable




#### ZCU102 design (HPC1)


	Ethernet FMC Port 0: XPAR_XEMACPS_0_BASEADDR


	Ethernet FMC Port 1: XPAR_XEMACPS_1_BASEADDR


	Ethernet FMC Port 2: XPAR_XEMACPS_2_BASEADDR


	ZCU102’s on-board Ethernet port: XPAR_XEMACPS_3_BASEADDR




#### ZCU106 design (HPC0)


	Ethernet FMC Port 0: XPAR_XEMACPS_0_BASEADDR


	Ethernet FMC Port 1: XPAR_XEMACPS_1_BASEADDR


	Ethernet FMC Port 2: XPAR_XEMACPS_2_BASEADDR


	Ethernet FMC Port 3: XPAR_XEMACPS_3_BASEADDR


	ZCU106’s on-board Ethernet port: Not usable




#### ZCU106 design (HPC1)


	Ethernet FMC Port 0: XPAR_XEMACPS_0_BASEADDR


	Ethernet FMC Port 1: XPAR_XEMACPS_1_BASEADDR


	Ethernet FMC Port 2: Not usable


	ZCU106’s on-board Ethernet port: XPAR_XEMACPS_3_BASEADDR




#### UltraZed, TE0808 design


	Ethernet FMC Port 0: XPAR_XEMACPS_0_BASEADDR


	Ethernet FMC Port 1: XPAR_XEMACPS_1_BASEADDR


	Ethernet FMC Port 2: XPAR_XEMACPS_2_BASEADDR


	Ethernet FMC Port 3: XPAR_XEMACPS_3_BASEADDR


	On-board Ethernet port: Not usable




#### BSP Setting


	When using ports that use AXI Ethernet IP, the BSP setting “use_axieth_on_zynq” must be set to 1.


	When using ports that use Zynq GEM, the BSP setting “use_axieth_on_zynq” must be set to 0.




To change BSP settings: right click on the BSP and click Board Support Package Settings from the context menu.

## Troubleshooting

Check the following if the project fails to build or generate a bitstream:

### 1. Are you using the correct version of Vivado for this version of the repository?
Check the version specified in the Requirements section of this readme file. Note that this project is regularly maintained to the latest
version of Vivado and you may have to refer to an earlier commit of this repo if you are using an older version of Vivado.

### 2. Did you correctly follow the Build instructions in this readme file?
All the projects in the repo are built, synthesised and implemented to a bitstream before being committed, so if you follow the
instructions, there should not be any build issues.

### 3. Did you copy/clone the repo into a short directory structure?
Vivado doesn’t cope well with long directory structures, so copy/clone the repo into a short directory structure such as
`C:projects`. When working in long directory structures, you can get errors relating to missing files, particularly files
that are normally generated by Vivado (FIFOs, etc).

## For more information

If you need more information on whether the Ethernet FMC is compatible with your carrier, please contact me [here](http://ethernetfmc.com/contact/ “Ethernet FMC Contact form”).
Just provide me with the pinout of your carrier and I’ll be happy to check compatibility and generate a Vivado constraints file for you.

## Contribute

We encourage contribution to these projects. If you spot issues or you want to add designs for other platforms, please
make a pull request.

## About us

This project was developed by [Opsero Inc.](http://opsero.com “Opsero Inc.”),
a tight-knit team of FPGA experts delivering FPGA products and design services to start-ups and tech companies.
Follow our blog, [FPGA Developer](http://www.fpgadeveloper.com “FPGA Developer”), for news, tutorials and
updates on the awesome projects we work on.





            

          

      

      

    

  

    
      
          
            
  
Modified BSP files

### lwIP modifications

The lwIP sources need a few small modifications to make it work with the Ethernet FMC.


	A function is added to xaxiemacif_physpeed.c for the initialization of the Marvell 88E1510 Ethernet PHY


	Defined the PHY address of the GMII-to-RGMII converter in xemacpsif_physpeed.c




### ZynqMP FSBL modifications

This project uses a modified ZynqMP FSBL to fix two issues:

1. The code used to read the FMC card’s EEPROM on ZCU104 has a bug that you can read about here:
https://forums.xilinx.com/t5/Xilinx-Evaluation-Boards/Enabling-VADJ-on-ZCU104/td-p/861259
2. The Trenz TEBF0808 board requires some modifications to configure the board clocks





            

          

      

      

    

  

    
      
          
            
  
PetaLinux Project source files

### How to build the PetaLinux projects

#### Requirements


	Windows or Linux PC with Vivado installed


	Linux PC or virtual machine with PetaLinux installed




#### Instructions

In order to make use of these source files, you must:


	First generate the Vivado project hardware design(s) (the bitstream) and export the design(s) to SDK.


	Launch PetaLinux by sourcing the settings.sh bash script, eg: source <path-to-installed-petalinux>/settings.sh


	Build the PetaLinux project(s) by executing the build-petalinux script in Linux.




The script will generate a separate PetaLinux project for all of the generated and exported Vivado projects that
it finds in the Vivado directory of this repo.

### UNIX line endings

The scripts and files in the PetaLinux directory of this repository must have UNIX line endings when they are
executed or used under Linux. The best way to ensure UNIX line endings, is to clone the repo directly onto your
Linux machine. If instead you have copied the repo from a Windows machine, the files will have DOS line endings and
you must use the dos2unix tool to convert the line endings for UNIX.


	Copy the cloned repository from your Windows machine to your Linux machine.


	Use the cd command to navigate to the copied repository on your Linux machine.




3. Type find . -type f -exec dos2unix –keepdate {} + to convert all of the files
to the Unix format.

### How the script works

The PetaLinux directory contains a build-petalinux shell script which can be run in Linux to automatically
generate a PetaLinux project for each of the generated/exported Vivado projects in the Vivado directory.

When executed, the build script searches the Vivado directory for all projects containing a .xsa exported
hardware design file. Then for every exported project, the script does the following:


	Verifies that the .bit file exists.




2. Determines the CPU type: Zynq or ZynqMP. It currently does this
by looking at the first 3 letters of the project name.
3. Creates a PetaLinux project, referencing the exported hardware design (.xsa).
4. Copies the relevant configuration files from the src directory into the created
PetaLinux project.
5. Builds the PetaLinux project.
6. Generates a BOOT.bin and image.ub file.

### Launch PetaLinux on hardware

#### Via JTAG

To launch the PetaLinux project on hardware via JTAG, connect and power up your hardware and then
use the following commands in a Linux command terminal:

1. Change current directory to the PetaLinux project directory:
cd <petalinux-project-dir>
2. Download bitstream to the FPGA:
petalinux-boot –jtag –fpga –bitstream ./images/linux/system.bit
If you don’t use the –bitstream option to specify the bitstream, then PetaLinux will download the
./images/linux/download.bit bitstream containing the FSBL. We don’t want to run the FSBL when
booting via JTAG.
3. Download the PetaLinux kernel to the FPGA:
petalinux-boot –jtag –kernel

#### Via SD card (Zynq)

To launch the PetaLinux project on hardware via SD card, copy the following files to the root of the
SD card:


	/<petalinux-project>/images/linux/BOOT.bin


	/<petalinux-project>/images/linux/image.ub




Then connect and power your hardware.

### Configuration files

The configuration files contained in the src directory include:


	Device tree


	Rootfs configuration (to include ethtool)


	Interface initializations (sets eth0-4 interfaces to DHCP)


	Kernel configuration


	AXI Ethernet driver patch




#### AXI Ethernet driver patch

The AXI Ethernet driver requires a patch for the correct configuration of the RGMII interface’s
RX and TX clock skews.

https://github.com/Xilinx/linux-xlnx/blob/master/drivers/net/ethernet/xilinx/xilinx_axienet_main.c


	```             } else if (lp->phy_type == XAE_PHY_TYPE_RGMII_2_0) {
	
	phydev = of_phy_connect(lp->ndev, lp->phy_node,
	axienet_adjust_link, 0,
PHY_INTERFACE_MODE_RGMII_ID);









```

The section of the code shown above specifies PHY_INTERFACE_MODE_RGMII_ID as the RGMII interface
mode (aka “rgmii-id”). That interface mode enables both the RX and TX clock delays in the PHY but in
fact we need to enable only the RX delay
(see http://ethernetfmc.com/rgmii-interface-timing-considerations/ for more information).

Our device tree specifies the correct RGMII configuration with the phy-mode setting (“rgmii-rxid”),
and we have access to this setting via the lp->phy_interface variable. So to correct the issue, we
replace the above code with the following:


	```             } else if (lp->phy_type == XAE_PHY_TYPE_RGMII_2_0) {
	
	phydev = of_phy_connect(lp->ndev, lp->phy_node,
	axienet_adjust_link, 0,
lp->phy_interface);









```

The included patch handles this modification - you do not need to manually modify any code.

#### ZCU104 ZynqMP FSBL patch for 2019.2

The FSBL for Zynq Ultrascale+ needs a patch to properly enable VADJ on the ZCU104 board in the 2019.2
version of PetaLinux. The FSBL released with this version of PetaLinux has code to read the FMC card’s
EEPROM and then enable VADJ to the correct value. The released FSBL code in fact reads from the ZCU104
board’s EEPROM and not the FMC’s EEPROM. It also only reads 32 bytes from the EEPROM, which is not
sufficient to include the VADJ voltage data. For both of these reasons, the FSBL does not properly
enable VADJ on this board.

There is a patch contained in this repo that fixes this issue so that VADJ is correctly enabled on
the ZCU104 board.

#### TEBF0808 ZynqMP FSBL patch

The FSBL for the TEBF0808 board needs some modifications to enable certain clocks before the bitstream
is loaded and application/OS is launched. To incorporate the modifications into the PetaLinux build,
this repo contains a patch for the FSBL located here:

<repo>/PetaLinux/src/tebf0808/project-spec/meta-user/recipes-bsp/fsbl/files/tebf0808_fsbl.patch

### Port configurations

#### MicroZed, PicoZed, ZC702, ZC706, ZedBoard


	eth0: Ethernet port of the dev board (GEM0)


	eth1: Ethernet FMC Port 3 (GEM1)


	eth2: Ethernet FMC Port 0 (AXI Ethernet)


	eth3: Ethernet FMC Port 1 (AXI Ethernet)


	eth4: Ethernet FMC Port 2 (AXI Ethernet)




#### ZCU104, ZCU102 (HPC0), ZCU106 (HPC0) and TEBF0808


	eth0: Ethernet FMC Port 0 (GEM0)


	eth1: Ethernet FMC Port 1 (GEM1)


	eth2: Ethernet FMC Port 2 (GEM2)


	eth3: Ethernet FMC Port 3 (GEM3)




Note that the Ethernet port of the dev board in these designs is not connected to any GEM and is
thus unusable.

#### ZCU102 (HPC1)


	eth0: Ethernet FMC Port 0 (GEM0)


	eth1: Ethernet FMC Port 1 (GEM1)


	eth2: Ethernet FMC Port 2 (GEM2)


	eth3: ZCU102 on-board Ethernet port (GEM3)




#### ZCU106 (HPC1)


	eth0: Ethernet FMC Port 0 (GEM0)


	eth1: Ethernet FMC Port 1 (GEM1)


	eth2: ZCU102 on-board Ethernet port (GEM3)








            

          

      

      

    

  

    
      
          
            
  
Vitis Project files

### Important patch for Vitis 2019.2

To use the build script in this directory, you must first apply the following patch
to your Vitis installation:

https://www.xilinx.com/support/answers/73252.html

### How to build the Vitis workspace

In order to make use of these source files, you must first generate
the Vivado project hardware design (the bitstream) and export the hardware.
Check the Vivado folder for instructions on doing this from Vivado.

Once the bitstream is generated and exported, then you can build the
Vitis workspace using the provided build-vitis.tcl script.

### Scripted build

The Vitis directory contains a build-vitis.tcl script which can be run to automatically
generate the Vitis workspace. Windows users can run the build-vitis.bat file which
launches the Tcl script. Linux users must use the following commands to run the build
script:
`
cd <path-to-repo>/Vitis
/<path-to-xilinx-tools>/Vitis/2019.2/bin/xsct build-vitis.tcl
`

The build script does three things:

1. Prepares a local Vitis repository containing a modified version of lwIP library,
required by the echo server example application.
2. Adds the ../EmbeddedSw directory as a local Vitis repository.
3. Generates a lwIP Echo Server example application for each exported Vivado design
that is found in the ../Vivado directory. Most users will only have one exported
Vivado design.

### Run the application


	Open Xilinx Vitis.




2. Power up your hardware platform and ensure that the JTAG is
connected properly.
3. In the Vitis Explorer panel, double-click on the System project that you want to run -
this will reveal the applications contained in the project. The System project will have
the postfix “_system”.
4. Now click on the application that you want to run. It should have the postfix “_echo_server”.
5. Select the option “Run Configurations” from the drop-down menu contained under the Run
button on the toolbar (play symbol).
6. Double-click on “Single Application Debug” to create a run configuration for this
application. Then click “Run”.

The run configuration will first program the FPGA with the bitstream, then load and run the
application. You can view the UART output of the application in a console window.

### UART settings

To receive the UART output of this standalone application, you will need to connect the
USB-UART of the development board to your PC and run a console program such as
[Putty](https://www.putty.org “Putty”). The follow UART settings must be used:


	Zynq and ZynqMP designs: 115200 baud




### How to change the Ethernet port targetted by the application

The echo server example design currently can only target one Ethernet port at a time.
Selection of the Ethernet port can be changed by modifying the defines contained in the
platform_config.h file in the application sources. Set PLATFORM_EMAC_BASEADDR
to one of the following values:

#### ZedBoard and MicroZed designs


	Ethernet FMC Port 0: XPAR_AXIETHERNET_0_BASEADDR


	Ethernet FMC Port 1: XPAR_AXIETHERNET_1_BASEADDR


	Ethernet FMC Port 2: XPAR_AXIETHERNET_2_BASEADDR


	Ethernet FMC Port 3: XPAR_XEMACPS_1_BASEADDR




#### ZCU102 designs (HPC0 and HPC1)


	Ethernet FMC Port 0: XPAR_XEMACPS_0_BASEADDR


	Ethernet FMC Port 2: XPAR_XEMACPS_1_BASEADDR




##### BSP Setting


	When using ports that use AXI Ethernet IP, the BSP setting “use_axieth_on_zynq” must be set to 1.


	When using ports that use Zynq GEM, the BSP setting “use_axieth_on_zynq” must be set to 0.




To change BSP settings: right click on the BSP and click Board Support Package Settings from the context menu.

#### TEBF0808 ZynqMP FSBL patch

The FSBL for the TEBF0808 board needs some modifications to enable certain clocks before the bitstream
is loaded and application/OS is launched. To incorporate the modifications, this repo contains a
modified version of the ZynqMP FSBL in the EmbeddedSw directory. The Vitis build script
sets the EmbeddedSw directory as a local software repository, thus all ZynqMP applications in the workspace
use the modified ZynqMP FSBL. However, the TEBF0808 specific modifications are braced with #if defined statements
so that they are only applied to the TEBF0808 design.
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